ผู้เขียน หัวข้อ: การตั้งค่าระบบ Social Login  (อ่าน 277 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ ผู้ดูแลระบบ

  • ยิ้มวันละนิด จิตแจ่มใส
  • Administrator
  • *****
  • กระทู้: 197
  • จิตใจสงบ ชีวิตเป็นสุข
    • ดูรายละเอียด
    • ศูนย์คอมพิวเตอร์และเครือข่ายวารินชำราบ
การตั้งค่าระบบ Social Login
« เมื่อ: วันที่ 30 มกราคม 2020, เวลา 15:02:03 pm »
การตั้งค่าระบบ Social Login



มีวิธีการดังต่อไปนี้
1. Login เข้าสู่ระบบ Cloud
2. กด เข้าจัดการ Hotspot




3. กดเข้าเมนูแก้ไข Hotspot




4. เลื่อนมาที่เมนู Social LOGIN มีการกำหนดค่าดังนี้
เปิดระบบ Social Login : เลือกเปิดระบบ social login
Like and Check in : เลือกให้ user like ครั้งแรก และครั้งต่อไปต้อง check in ถึงใช้ internet ได้
Like only : เลือกให้ user like อย่างเดียว
Facebook Fan Page Url : กรอก fan page url
Facebook Page ID : กรอก fan page id
Enable Social List : เลือก social media ที่ต้องการใช้งาน




5. ทำการ Save เพื่อให้ระบบบันทึกข้อมูล
6. สร้าง billing plan สำหรับ Social Login โดยไป ที่เมนู Billing Plan ตั้งชื่อ plan




และ กด advance setting และเลือก Social Login โดยสามารถเลือกได้ว่า จะให้ user ใช้งานได้ทันที หรือ ต้องรออนุมัติก่อน




7. ทำการตั้งค่าอุปกรณ์ Mikrotik ให้รองรับ Social Login โดยการไปที่เมนู ตั้งค่า เมนู Generate scripts




กดเลือก social Login และกด Generate scripts หลังจากนั้น copy ข้อมูล ตามตังอย่างในภาพ






/ip hotspot walled-garden add action=allow disabled=no dst-host=*.facebook.com comment=*.facebook.com
/ip hotspot walled-garden add action=allow disabled=no dst-host=*.facebook.net comment=*.facebook.net
/ip hotspot walled-garden add action=allow disabled=no dst-host=*.xx.fbcdn.net comment=*.xx.fbcdn.net

/ip hotspot walled-garden ip add action=accept disabled=no dst-host=www.facebook.com comment=www.facebook.com
/ip hotspot walled-garden ip add action=accept disabled=no dst-host=m.facebook.com comment=m.facebook.com
/ip hotspot walled-garden ip add action=accept disabled=no dst-host=www.facebook.net comment=www.facebook.net
/ip hotspot walled-garden ip add action=accept disabled=no dst-host=connect.facebook.net comment=connect.facebook.net

แล้วนำมาวางใน Mikrotik > new terminal และ กด Enter




เป็นอันเสร็จขั้นตอนการตั้งค่าระบบ Social Login